[Vcsn] installation problem with boost/python.hpp

Daniel Krenn daniel.krenn at aau.at
Tue Mar 15 12:39:53 CET 2016


Dear Vaucanson-team,

I'm trying to install Vcsn 2.2 on Linux Mint 17.3 (based on Ubuntu
14.04). I've installed the package libboost-all-dev (details below),
which includes libboost-python-dev. However, configure fails with
  checking boost/python.hpp usability... no
  checking boost/python.hpp presence... no
  checking for boost/python.hpp... no
  configure: error: cannot find boost/python.hpp
A file
  /usr/include/boost/python.hpp
exists. The same problem occurs when using the git-repository (branch at
1c87ba8) directly

Any ideas what could be wrong?

Kind regards

Daniel Krenn


installed packages:
-------------------

libboost-all-dev
Version: 1.54.0.1ubuntu1
Depends: libboost-dev, libboost-tools-dev, libboost-atomic-dev,
libboost-chrono-dev, libboost-context-dev, libboost-coroutine-dev,
libboost-date-time-dev, libboost-exception-dev, libboost-filesystem-dev,
libboost-graph-dev, libboost-graph-parallel-dev, libboost-iostreams-dev,
libboost-locale-dev, libboost-log-dev, libboost-math-dev,
libboost-mpi-dev, libboost-mpi-python-dev, libboost-program-options-dev,
libboost-python-dev, libboost-random-dev, libboost-regex-dev,
libboost-serialization-dev, libboost-signals-dev, libboost-system-dev,
libboost-test-dev, libboost-thread-dev, libboost-timer-dev,
libboost-wave-dev

libboost-python-dev
Version: 1.54.0.1ubuntu1
Depends: libboost-python1.54-dev

libboost-python1.54-dev
Version: 1.54.0-4ubuntu3
Depends: libboost1.54-dev (= 1.54.0-4ubuntu3), libboost-python1.54.0 (=
1.54.0-4ubuntu3), libpython-dev | libpython3-dev


More information about the Vaucanson mailing list