[Spot] spot-2.6.1 conflicts with libiconv-1.14: it installs the file lib/charset.alias

Alexandre Duret-Lutz adl at lrde.epita.fr
Fri Aug 10 22:29:13 CEST 2018


On Fri, Aug 10, 2018 at 7:51 PM Yuri <yuri at rawbw.com> wrote:
> Installing on the FreeBSD. Using the port that I created https://www.freshports.org/math/spot/

I'm glad to see that.  Thanks for the port!

> I had to delete lib/charset.alias from the package in order for it to be installed.

This file is installed by most packages that uses gnulib (in fact,
it's installed OR updated because each package is expected to add a
comment to the file as a kind of reference counter to know when the
file can be removed).
Looking at the ports for GNU Bison or GNU grep, which also use gnulib,
I see that they have

USES = charsetfix

and that seems to be the FreeBSD way around this:

https://www.freebsd.org/doc/en/books/porters-handbook/uses-charsetfix.html
-- 
Alexandre Duret-Lutz


More information about the Spot mailing list