[Spot] Python Binding Issue

Yoonchang Sung yooncs8 at csail.mit.edu
Tue Feb 18 18:21:38 CET 2020


To whom it may concern,

I am having Ubuntu 16.04 and my python3 version is 3.5.2 (default version
from Ubuntu 16.04). After installing with the default configuration setting
(installing from a tarball), I am able to import spot in python3 but
"print(spot.version())" gives me this error: "AttributeError: module 'spot'
has no attribute 'version'".
Also, when trying "sudo apt-get install python3-spot", I am getting this
error: "The following packages have unmet dependencies:
 python3-spot : Depends: python3 (>= 3.7~) but 3.5.1-3 is to be installed
E: Unable to correct problems, you have held broken packages."
I was wondering if you could help me with this issue. Thank you!

Best,
Yoon

-- 
*Yoonchang Sung*

Postdoctoral Associate

Massachusetts Institute of Technology
Computer Science and Artificial Intelligence Laboratory
32 Vassar St. / Room 32-335
Cambridge, MA 02139
USA
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lrde.epita.fr/pipermail/spot/attachments/20200218/34735289/attachment.htm>


More information about the Spot mailing list