[Spot] Python Binding Issue

Alexandre Duret-Lutz adl at lrde.epita.fr
Wed Feb 26 13:57:51 CET 2020

Dear Yoonchang,

On Wed, Feb 26, 2020 at 10:13 AM Yoonchang Sung <yooncs8 at csail.mit.edu> wrote:
> I am having Ubuntu 16.04 and my python3 version is 3.5.2 (default version from Ubuntu 16.04). After installing with the default configuration setting (installing from a tarball), I am able to import spot in python3 but "print(spot.version())" gives me this error: "AttributeError: module 'spot' has no attribute 'version'".

So what else is in this spot module that was imported?    Could you try

>>> import spot
>>> dir(spot)

Maybe you have something else called spot installed on your computer
(E.g. https://pypi.org/project/spot/), and it gets loaded instead?

> Also, when trying "sudo apt-get install python3-spot", I am getting this error: "The following packages have unmet dependencies:
>  python3-spot : Depends: python3 (>= 3.7~) but 3.5.1-3 is to be installed
> E: Unable to correct problems, you have held broken packages."
> I was wondering if you could help me with this issue.

Yes, those Debian packages are built with the default version of
Python available on the current version of Debian.   They are unlikely
to work on a 4-year old release of Ubuntu.  On your setup manual
compilation & installation is the safer way.

Alexandre Duret-Lutz

More information about the Spot mailing list